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The practical has been tailored to QGIS 1.8.0, as this is the version of the software available on the 

computers in the lab. Should you wish to download and use QGIS on your own computer, the latest 

version of the software will look a bit different than 1.8.0, but the concepts and tools will be similar 

(though they may need to be done in a different way). 

Spatial Projections 

 

-Download the files for the practical from 

www.patrickrickles.com/tutorial/files/QGIS/Practical_2/Practical_2_data.zip. Unzip them, and store 

them in a location of your choice. 

-Open QGIS Desktop (1.8.0) 

-If it’s not already available, fetch the plugin for the Google Maps layers by going to Menu Bar > 

Plugins > Fetch Python Plugins 

 

(Note: This may take a little bit and there may be some error messages from repositories that may 

not be accessible; close these error messages and the window for the plugins will open) 

 

 

-In the Filter space, type: “google”  

-Select OpenLayers Plugin 

-Click Install plugin 

(Note: if the plugin has already been installed, this will say Upgrade or Reinstall Plugin. If that is the 

case, simply click Close, as we only want to ensure the Plugin is installed.) 
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-Load the Basemap from the plugin  

-Menu Bar > Plugins > OpenLayers plugin > Add Google Physical Layer 

 
 

-Please also import a raster image layer for the area, 

/Raster/peru_vegatation_and_weather_map_motified.tif, which can be done by selecting Layer > 

Add Raster Layer. 

 

-QGIS allows you to define a CRS (Coordinate Reference System) for layers as well as for the entire 

project. You will need to define the CRS for layers without a pre-defined one, which can happen if 

this information has not been set yet or has been lost. To define the project-wide CRS, select 
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Settings > Project Properties> CRS and select PSAD56.   Similarly, you can select WGS 84 for the 

project-wide CRS.  
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(Note: Sometimes the find function doesn’t work. You can find PSAD56 in projected coordinate 

systems or may search for it via the Filter by inputting PSAD56 or EPSG:24891) 

 

-At this point you may not be in a familiar view, right click the 

peru_vegetation_and_weather_map_modified.tif layer and select “Zoom to Layer Extent” to go to it.  

-At the bottom of QGIS window, you will notice the label “Coordinate”. As you move your cursor 

over the map, it will show you the X,Y coordinates at that location. At the bottom-right corner you 

will see EPSG:24891 . This is the code for the current ‘Project CRS’ PSAD56.  
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-Now switch back to WGS84 / Pseudo Mercator EPSG:3857 in the same way as you just did to 

change the Coordinate Reference System to PSAD56.  

-Load a vector layer to the map. Select Layer-> Add Vector Layer. Select peru_administrative from 

the files downloaded earlier. To determine the layer’s projection, right click on it and select 

Properties.  
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-In the Properties dialog, click on the Metadata tab. You will see the projection definition of the layer 

under ‘Layer Spatial Reference System’. You can see that the layer’s projection is WGS84. 

 

-Let’s say you need to use data with no pre-set projection - what are the steps for setting a vector 

layer in the right projection? Open the layer peru_highway_no_projection from the folder 

/Vaster/peru_highway_no_projection/peru_highway_no_projection.  

-As the layer has no pre-defined projection, you will be asked to specify a coordinate reference 

system. Select WGS84 / Pseudo Mercator and click OK.   
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-Right-click on the peru_highway layer and select Zoom to Layer Extent; then zoom out. The layer 

will appear in the wrong place – South of Western Africa in the Atlantic Ocean. 

 

-This is a common problem when working with data, as a projection may not have been set when 

the file was created. Ideally you would like to see the layers overlaid on top of each other in the 

same coordinate-space. In order to do this, first remove the layer you import and load it again. In the 
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coordinate reference system selector, choose a different projection (WGS84) and click OK. You can 

see the layer is in the right place.  

 

 

-In order to ensure that a dataset with no projection shows up in the right place, you may need to do 

this a few times and try a different coordinate reference system. Common ones for your work will 

be: WGS84 (e.g. GPS), WGS84 / Web Mercator (e.g. Google Maps), and PSAD56 (e.g. local Peruvian 
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datasets). Should any agencies give you data without a coordinate reference system, you should be 

able to set that properly now. 
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Attribute Queries 

 

-Vector layers in GIS have two parts - features (each geographical element in the layer is a feature) 

and attributes (tabular information about each of the features, which are stored in what’s called the 

attribute table). Here you will carry out some basic operations on the attribute table using Quantum 

GIS. Using the layer peru_highway, the task is to find all tertiary roads which are one-way in the Peru 

road network.   

-Right-click on the layer name and select ‘Open Attribute Table’.  

 

-We are interested in the type of each feature, so TYPE is one of the fields we are looking for. You 

can click on the field header to sort the column in ascending or descending order.  

-The other field you need is ONEWAY - it has information whether a road is one-way.  
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-In the bottom-right corner type “tertiary”, select TYPE as the column to search in and press Search. 

 

You will see the selected records highlighted in the attribute table. You can click the ‘Move selection 

to top’ button on bottom-left to bring all selected records to the top.  
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-If you look at the map area, the selected roads will be highlighted in yellow. 

(Note: It may be difficult to see the highlighted features, in which case, you may wish to switch some 

layers off to better see them.)  
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-Now, let’s refine the query to select only those roads which are one-way. The field containing this 

data is ONEWAY. In the attribute table, check the box ‘Search selected records only’ and type “yes” 

in ONEWAY and click Search.   
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-You can see that the selection changes to highlight only those roads that are both tertiary and one-

way.  
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-Now let’s export this selection to a new file. Right click on the layer and select ‘Save selection as...’  

 

-Browse to appropriate directory and name the output file as ‘tertiary_oneway_roads.shp’ and click 

OK. 

 

-Import the new layer in the map – you can see the concentration of one-way tertiary roads is along 

the coastline of Peru.  
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(Note: You may need to change the symbology to see the layer properly or turn off some layers) 

-Now let’s see how to do attribute queries based on numerical values. Open the vector layer 

peru_administrative, right-click on the layer and open its attribute table.  

 

-Let’s look for administrative borders with administrative level equal or higher than 5. We need the 

column ADMIN_LEVE. Click on Advanced search.  
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-When the search query builder window opens, double-click the field “ADMIN_LEVE” in Fields. It will 

then appear in SQL where clause. Add the text “>= 5” and click OK.  

 

-All features with administrative level equal or higher than 5 are selected both in the table and the 

map.  
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Attribute Joins 

 

-Let’s say you have data for the street network in different vector files. One file is peru_highway, 

which contains the name, type, number of lanes and direction of the streets. The other file is 

peru_street_length, which has information on the length of the streets.  

- peru_highway: 

 

- peru_street_length: 

 

-The task is – how to join the two tables in one? First, open both layers in QGIS.  
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-Now we will join the two layers. Double-click on the peru_highway layer to open Properties dialog. 

Go to the ‘Joins’ tab. 
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-Click on the ‘+’ to create a new join. Select peru_street_length as a join layer.  The ‘Join field’ will be 

the unique identifier from the peru_street_length data- select ID. The target field will be the unique 

identifier from the peru_highway layer- select ID. Click OK. Once the join is created, click OK and 

return to the QGIS canvas. 

 

 

-Now right-click on peru_highway to see its attribute table: 
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-You will notice that the table now contains additional fields taken from the street length file. 

 

-Remember that this ‘join’ is temporary. It is not part of the attribute table for the peru_highway 

layer, but just linked dynamically to the peru_street_length layer. If you want to permanently join 

the attributes, you must save it as a new layer. Right click on the peru_highway layer, select “Save As 

...”. Name the new layer ‘peru_highway_length.shp’ 
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Spatial Queries 

 

-Spatial queries are core to many GIS analysis. The example here demonstrates how to do spatial 

queries. The question we will try to answer is, ‘Which town centres in Peru are within 10 km of a 

water source?’.  

-Load the Vector layers ‘peru_location’, which represents town centre information, and 

‘peru_water’, which represents water sources from the Vector folder, which will be where you 

originally downloaded and unzipped the files for this practical. 

 

-These layers need to be reprojected to a coordinate system in metres, so we could run our queries 

in that instead of lat/long. Reprojection is part of the ‘Save As’ menu. This menu can be brought up 

by right clicking on a layer. In the ‘Save as...’ dialog, select ‘PSAD56/Peru west zone’ as the CRS and 

save the output file as ‘peru_location_reprojected.shp’. Similarly save the other layer as 

‘peru_water_reprojected.shp’  
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-Once the reprojection is done. Remove the existing layers and add the re-projected layers to your 

project.  

 

-To answer some spatial queries, further processing of the information may be needed in which we 

combine datasets or we extract parts common to both datasets (or perhaps the opposite) – this is 

commonly known as “geoprocessing”. In the next part, we will buffer the existing dataset to 

highlight information that falls within this proximity; in the Geoprocessing Tools of QGIS, the 

functions are as follows: 

• Convex Hull: Creates the smallest possible convex polygon enclosing a group of objects 

• Buffer: Creates an equal zone around specific features at a specified distance 

• Intersect: Creates a new layer based on the area of overlap of two layers 
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• Union: Melds two layers together into one while preserving features and attributes of both 

• Symmetrical Difference: Creates a new layer based on areas of two layers that do not 

overlap 

• Clip: Cuts a layer based on the boundaries of another layer 

• Difference: Subtracts areas of one layer based on the overlap of another layer 

• Dissolve: Merges features within a single layer based on common attributes in the attribute 

table 

(Note: For further information on all of these functions, please review the following presentation - 

http://www.slideshare.net/swethaashok28/geoprocessing-in-qgis) 

-Now that we are familiar with the terms, we will buffer both the peru_water_reprojected layer by 

10,000 metres (10km). Use Vector > Geoprocessing Tools > Buffer for this operation.  

 

-Use 10,000 as the buffer distance since our projection uses ‘metres’ as units. Click the Dissolve 

buffer results button so that overlapping buffers are merged. 
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-Save the layer as peru_water_reprojected_buffer.shp. 

-Once the buffering is done, add the layer to your project. You may wish to zoom in a bit to view 

some of the buffers better. 

 

-Now we are ready to run the spatial query to find out our answer to “Which town centres in Peru 

are within 10km of a water source?”.  
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-Open the plugin from Vector > Spatial Query. 

(Note: You may need to enable it from Plugins > Manage Plugins, if it is not there already.)  

-We want to select all locations that intersect with the buffered water polygon. Select the options as 

shown below and click Apply. 

 

-The new selection will highlight the regions that match the query. This is the answer we are looking 

for. Click Close and see the highlighted features from the location layer. 
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-Right-click the peru_location_reprojected layer and save selection as peru_location_10KM_water 
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-Now we can see all locations within 10KM of a water source.  
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Importing Data: Layers from Data Collectors (GPS) 

 

-GPS Units and other data collector programs/apps can be used to collect data in the field that can 

later be transferred to a PC for processing. From a GPS, the file formats will often be .gpx, .csv, .xml, 

or .txt; with other programs/apps, file formats may vary, though the process of importing is often 

the same. 

  

-To add GPS waypoints/tracks/routes to QGIS, you will first need to move them to the computer; 

downloaded with the other files for this practical, a GPX file has been included as an example. Select 

Layer > Add Vector Layer and select the GPX file type from the list in the browse data box (GPS 

Exchange format (GPX)).  



                                                                     QGIS Practical 2 

 

Page 33 of 42 

 

 

-Chose /Vector/peru_Health_care.gpx from where you downloaded the files for the practical. 
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-Then, a window will come up asking you to choose which GPX sublayers to load. Waypoints is the 

one to import this houses in the collected information on healthcare points.  

 

-A layer is added to the map holding all healthcare points in Peru. You can explore the attributes of 

the GPX data by right-clicking on its name and selecting Open Attribute Table.  
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-Alternatively, to identify the name of a particular point, select the Identify features button and click 

on the point. Then, a window with the results will come up.  
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Importing Data: Layers from Online (Web Mapping Services and Web 

Feature Services) 

 

-Some layers of information already exist on remote servers that may be accessible if you know 

where they’re at on the internet (and if you have the right username and password if it’s required). 

These are known as Web Mapping Services (WMS) (if they serve raster information) or Web Feature 

Services (WFS) (if they serve vector information). One site that lists a series of these sources can be 

found here: http://www.geoidep.gob.pe/index.php/catalogo-nacional-de-servicios-web/servicios-

de-visualizacion-wms  

 

-Looking under the available WMSs on this site, we can see what’s available. Find the WMS 

“Gobierno Regional de Cajamaca” under WMS por Entidad > Gobierno Regional de Cajamarca > 

Informacion Base and click on Detalle to open a pop up showing the WMS information, which has 

the URL: 
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http://sigr.regioncajamarca.gob.pe:6080/arcgis/services/Map/Informacion_Base/MapServer/WMSS

erver?request=GetCapabilities&service=WMS. If you go to that site, you will see the following:  

 

-Though this information may not be readable, it contains the information the GIS needs to connect 

to the remote server and load the information from it. Copy the URL from the WMS page, as this will 

be needed in a moment. In QGIS, select the menu option Layer > Add WMS Layer and the Add 

Layer(s) from a Server window will open up. Inside of this window, click the New button to add a 

new connection, which will open the Create a new WMS connection window. In this window, paste 

the URL from the WMS page in the URL field and let’s Name this layer Informacion Base. Once done, 

click OK. 
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-With the information for the connection entered, you’ll be taken back to the Add Layer(s) from 

Server window. Click the Connect button to connect to the server and get the information about the 

service inside QGIS. Select the layer Informacion_Base (which is an amalgamation of all the layers) 

and click Add to add it to the map and once it’s been added to the map, click Close to close the 

window. 
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-We can now see the Informacion Base layer added to the map. 
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-As the information is remotely controlled, we don’t have the ability to change the colours 

representing the various classes of information in this layer. To find out further information about 

the layer, though, you can right click on the layer and select properties and check out the Metadata 

tab. If the WMS is being published by a reputable source, it will often have associated metadata 

recorded about it which can be reviewed and may provide further information on how the data 

were compiled, what the colour classifications are, and other information that may be helpful in 

determining if this is the information you need for your map. 
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-Loading a WFS is done in roughly the same way, but instead of selecting Layer > Add WMS Layer, 

select Layer > Add WFS Layer. The most difficult part of either will be to find (verifiable) resources 

that provide you the information you need for your map. 


