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The practical has been tailored to QGIS 1.8.0, as this is the version of the software available on the 

computers in the lab. Should you wish to download and use QGIS on your own computer, the latest 

version of the software will look a bit different than 1.8.0, but the concepts and tools will be similar 

(though they may need to be done in a different way). 

Familiarising Yourself with QGIS 

 

-Download the files for the practical from 

www.patrickrickles.com/tutorial/files/QGIS/Practical_1/Practical_1_data.zip. Unzip them, and store 

them in a location of your choice. 

 

-Open QGIS Desktop (1.8.0) the program and familiarise yourself with it. 

The QGIS user interface is divided into five areas: 

 

1. Menu Bar – at the top of the interface (e.g. File, Edit, View, etc.). 

2. Tool Bar – Just below the Menu Bar with QGIS Tools (e.g. Add Vector, Pan, etc.). 

3. Layers Panel – Panel on the left that shows all the layers that are loaded into the map. 

4. Map Panel – Panel on the right that shows the map and visible layers. 

5. Status Bar – at the bottom of the interface that shows current coordinate of mouse, scale, 

coordinate reference system, etc. 

 

 

(Note: To see a video tutorial on QGIS interface, please refer to the following website: QGIS 1 

Introduction: https://www.youtube.com/watch?v=59Oer-i6nVc. The tutorial is for an older version 

of QGIS, but the same principles apply.) 

-Fetch the plugin for Google Physical Layer 
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-Menu Bar > Plugins > Fetch Python Plugins 

(Note: This may take a little bit and there may be some error messages from repositories that may 

not be accessible; close these error messages and the window for the plugins will open) 

 

-Under Filter enter “google” 

-Select OpenLayers Plugin 1.0.0  

-Click Install plugin 

(Note: if the plugin has already been installed, this will say Upgrade or Reinstall Plugin. If that is the 

case, simply click Close, as we only want to ensure the Plugin is installed.) 
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-Load the Basemap from the plugin  

-Menu Bar > Plugins > OpenLayers plugin > Add Google Physical Layer 

 

-Explore the Basemap using the Map Navigation to understand the Map Layers 
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Map Navigation (Menu Bar > View) 

 

 

-Tools for navigation are accessible by the View Menu, some of which are: 

• Pan Map 

• Zoom In 

• Zoom Out 

• Zoom to Layer 

• Zoom to Selection 

• Zoom Full  

 

-Others are accessible by right-clicking on the layer name. This displays the layer menu that includes 

a number of items that allow you to: 

 

• Open the Properties dialog  

• Remove the layer from the map 

• Set the transparency using a slider control  
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(Note: To see a video tutorial on QGIS tools for navigation, please refer to the following website: 

QGIS 2 Tools: https://www.youtube.com/watch?v=AsC_AEqtRRI. The tutorial is for an older version 

of QGIS, but the same principles apply.) 
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Map Layers  

 

-A layer is the visual representation of a geographic dataset in any digital map environment. 

Conceptually, a layer is a slice of the geographic reality in a particular area, and is more or less 

equivalent to a legend item on a paper map.  

-There are two main types of geographic datasets in GIS: vector and raster, which represent 

geography in different ways. Vector data represents discrete information (e.g. points, lines, 

polygons), whereas raster data represents continuous information (e.g. images). 

-The Basemap Google Physical is essentially a raster layer. It can be added and removed from the 

Map View by right-clicking on the layer name in the Map Legend.  

 

-Remove the Google Physical Layer and change it with Google Satellite Layer from Plugins > 

OpenLayers plugin > Add Google Satellite Layer.  
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-Load the Google Physical Layer again from Plugins > OpenLayers plugin > Add Google Physical layer. 

You now have two layers active in the Map Legend: 

 

  -To turn a layer off, uncheck the box next to layer by clicking it 
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-To change the drawing order of layers, drag the layer name up or down to bring forward or send 

backward  

-Right-click on the layer name in the legend and make sure the Update Drawing Order box is checked 

-Drag the layer name up or down to bring it forward or send backward. 
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Add Raster Layer 

 

-Raster layers represent continuous geographic information via grid cells. Quantum GIS (QGIS) 

supports most vector formats such as JPEG & TIFF. 

-Import the raster image layer /Raster/peru_vegatation_and_weather_map_motified.tif.* by 

choosing the Layer menu > Add Raster Layer 

(Note: This will be from where you unzipped the files that you downloaded at the beginning of the 

practical) 

 

*In GIS, a raster layer would have georeferencing data associated with it which will allow it to be 

positioned correctly in the map display to allow other vector and raster data to be overlaid with it. 

QGIS makes use of georeferenced rasters to properly display the data. This will be covered later in 

the practical. 

 

-To change a raster layer’s transparency, right click the Raster Layer in the Map legend  then select 

Properties  > Global Transparency. Here you can adjust the value of transparency.  
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Add Vector Layer 

 

-Vector layers represent discrete geographic information via points (a set of coordinates), lines (a 

series of points), or polygons (a series of connected lines). QGIS supports vector data in a number of 

vector data formats, such as ESRI shapefiles (shp).  

 

-To load a shapefile, choose the Layer menu > Add Vector Layer.  

 

-This will bring up a new window. Click on Browse. That will bring up a standard open file 

dialog which allows you to navigate the file system and load a shapefile . 

 

 

-Open the Vector shapefiles that were included with the practical (originally downloaded from: 

http://download.geofabrik.de/south-america/peru.html). Once loaded, you can zoom around the 

shapefile using the map navigation tools.  
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(Note: When you load the file(s) you may be prompted to select a Coordinate Reference System 

[CRS]. This is so the GIS knows where to locate the data you are trying to load. There are three CRS 

that you will need to be aware of for your work in Peru: PSAD56 [EPSG: 24891, CRS local to Peru that 

is often used by government organisations], WGS84 [EPSG: 4326, global CRS used by GPS] and 

WGS84/Pseudo Mercator [EPSG: 3857, global CRS used by Google Maps, Bing Maps, etc.]. For now, 

please select WGS84/Pseudo Mercator [EPSG: 3857]) 
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Create Vector Data 

 

-In this exercise you are going to digitise the information that you created on the printed maps.  

-Steps to add new Shapefile: Layer > New > New Shapefile Layer 

 

 

-This opens a window where you can choose the type of shape file you want to create; a point, 

polyline (line) or polygon (area): 
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-Choose polygon 

-Specify the WGS 84 EPSG:4326 coordinate system in the CRS field 

-Give the file a name (Peru_Polygon)  

-Click Add to attributes list button 

-Press OK and save as the same file name (Peru_Polygon) in an appropriate folder 

 

-The new shapefile you created is now loaded as a new layer  to the workspace before you can start 

drawing in it: 
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-Turn off all other layers and leave only the Peru_Polygon layer on. You can now edit this layer by 

right clicking the layer and selecting ‘toggle editing’. 

 

 

-Select Edit > Add Features to start drawing the polygon.  
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-To save your edits right click once you are done and click OK on the window that pops up. You can 

then toggle editing off. It will prompt you to save changes if necessary. 
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-You can also delete the feature by selecting it from Edit > Delete Selected.  

 

-For adding or deleting new features from a layer, remember to set the layer in Editing mode as 

described before.  
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Adding Attribute Data      

 

-You have now created a new feature in the Peru_Polygon layer. Vector layers in GIS (such as 

Peru_Polygon)  have attributes – diferent numerical values associated with them. This information 

can be seen and manipulated from the Attributes tab.  

 

-To open the Attributes table of Peru_Polygon, right-click on the layer name and select Open 

Attribute Table.  
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-The attributes of the selected dataset can be manipulated.  

-When editing of the layer is enabled, the Edit button will be pressed you can modify and change the 

values in the table. In this case, there are two columns- an ID column for unique values and a name 

column for description.  

-The New Column button and Delete Column button can be used, when the layer is Editing mode. 

Mouse over the buttons to identify those now from the hover tool tip information.  

 

-Once you are done, you can Save Edits and Unselect Features. Again, mouse over the buttons to 

identify those now from the hover tool tip information. 

 

-You can similarly create point and line shapefiles as you did the polygon file. Feel free to create 

some to experiment with, if you wish. 

  



QGIS Practical 1 

 

Page 22 of 42 

 

Symbolising Information 

 

-To change the symbology of a layer (such as changing its colours, lines, fills) , open the Layer 

Properties dialog by double clicking on the layer name or by right-clicking on the name in the legend 

and choosing Properties > Style from the popup menu. 
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(Note: To see a video tutorial on QGIS symbology tools, please refer to the following website: QGIS 3 

- Symbology: https://www.youtube.com/watch?v=duuYMufA-RU. The tutorial is for an older version 

of QGIS, but the same principles apply.) 
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Georeferencing a Raster 

 

-Activate the Georeferencer plugin from Plugins > Manage plugins > Georeferencer GDAL if it’s not 

already activated.  

 

 

-Choose Raster > Georeferencer 
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(Note: This is the location of the Georeferencer tool in QGIS 1.8.0. The location may be different in 

different versions of QGIS. To see find out more information on georeferencing, please refer to 

following links: https://www.youtube.com/watch?v=Cb_qrNh_6_Q and 

http://www.qgistutorials.com/en/docs/georeferencing_basics.html) 

-A new plugin window like below will pop-up. The plugin window is divided into 2 sections. The top 

section where the raster will be displayed and the bottom section where a table showing your 

Ground Control Points (GCP), used for georeferencing, will appear. If you wish, you may drag the 

GCP window and separate it from the top section. Now click on the ‘Open Raster’ button on top-left 

corner. 
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-Browse to the location where you downloaded the stored the files downloaded from Moodle, find 

the JPG image of the scanned map and click Open /Raster/peru_vegetation_and_weather_map.jpg. 

 

 



QGIS Practical 1 

 

Page 27 of 42 

 

-In the next screen, you will be asked to choose the raster’s Coordinate Reference System (CRS). This 

is the projection of your control points. If you are geo-referencing a scanned map or a downloaded 

image, choose WGS84 (World Geographic System).   

 

-Next, you will see the image will be loaded on the top section. You can use the zoom/pan controls 

in the toolbar to learn more about the map.  
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-To assign coordinates, click on ‘Add Point’ button and select points of visual reference from the 

image by clicking on the map on recognisable features (e.g. the small bit of the coastline jutting out 

South of Lima).  
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-In the pop-up window, enter the coordinates by clicking the From map canvas button - this is to 

visually reference the image with the basemap from OpenLayers.   
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-Select the same point on the canvas (e.g. the small bit of the coastline jutting out South of Lima) 

and then click OK in the coordinates window.  

 

-This will create a geo-referenced point in the Georeferencer window. You will notice the GCP table 

now has a row with details of your first control point.  
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-Similarly, now choose more control points from the new raster image and georeference them 

picking the relevant point from the canvas.  The more points you have, the more accurate the 

georeferencing will be. Should you wish to remove any points from the list, right click the row and 

select “Remove”. 

(Note: If you use navigation tools to zoom in the canvas when selecting the points, you’ll need to go 

back to the Georeferencer window and click “From map canvas” again.) 
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-Once you are done, click on Settings > Transformation Settings. In the Transformation settings 

dialog, you will have to choose multiple parameters. Give the output raster a name and set out 

‘Target SRS’ as WGS84/Pseudo Mercator (EPSG:3857), so the resulting georeferenced image file will 

have a CRS of WGS84/Pseudo Mercator (EPSG:3857). Make sure you check the ‘Load in QGIS when 

done’ button at the bottom. Click OK. 
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-Now click the ‘Start georeferencing’ button from the toolbar. 
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-Once the process is complete, you will see the georeferenced raster image loaded in your QGIS 

canvas. To check if the georeferencing is accurate make the new layer semi-transparent (right-click 

the layer and select Properties> Transparency).  
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Print a Map 

 

-The print composer provides growing layout and printing capabilities. It allows you to add elements 

such as the QGIS map canvas, legend, scale bar, images, basic shapes, arrows and text labels. You 

can size, group, align and position each element and adjust the properties to create your layout. The 

layout can be printed or exported to image formats.  

-To activate Print composer, select File > New Print Composer 

 

-Opening the print composer provides you with a blank canvas to which you can add the current 

QGIS map canvas, legend, scale bar, images, basic shapes, arrows and text. 
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- Adding a current QGIS map canvas to the Print Composer: 

-To add the QGIS map canvas, click on the Add new map button in the print composer toolbar and 

drag a rectangle on the composer canvas with the left mouse button to add the map. 

 

 

-The current map is now displayed in Printer Composer: 
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-You can resize the map element by clicking on the Select/Move item button (again, you can hover 

over the buttons and identify their purpose by reading the tool tip information), selecting the 

element, and dragging one of the blue handles in the corner of the map. Should you update your 

map and need to update what’s seen in the Print Composer, click on the Update Preview button in 

the Item Properties window. 
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(Note: To see more information on Print Composer look, please refer to the QGIS User Guide: 

http://download.osgeo.org/qgis/doc/manual/qgis-1.8.0_user_guide_en.pdf)  

-Adding cartographic elements to the map in Print Composer: 

-To add a legend, click the Add new legend button 

 

-To add a scale bar click the Add new scale bar button 
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-To add a north arrow, click the Add Image button and chose a north arrow from the Picture options 

in Item Properties.  

 

-Once the map looks how you want it to look, right click the File menu to either export the map as a 

PDF, image, or SVG or send it to a printer to be printed. 
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-When you’re finished with your map, should you wish, go back to the main QGIS window and under 

the File menu, select File > Save Project and save it to a location of your choice. 

 

 


